首页 > 服务器 > 麒麟v10安装docker

作者:ghostry 发布时间:2023-04-19 浏览: 1868

转载注明出处: https://blog.1ge.fun/server/1073.html
curl -sSL https://get.daocloud.io/docker | sh

常规操作,以为能装上的,结果就报错了。
依赖问题无法安装。

单独执行

apt-get install docker-ce

提示

docker-ce : 依赖: containerd.io (>= 1.6.4) 但是它将不会被安装

然后又安装 containerd.io 提示

containerd.io : 依赖: libseccomp2 (>= 2.5.0) 但是 2.4.3-1kylin3.20.04.3k5 正要被安装

仓库里版本有点低。
在网上找到了这个

mkdir foo && cd foo
sudo apt-get update
sudo apt build-dep libseccomp2
apt-get source --compile libseccomp2
sudo dpkg -i libseccomp2_*.deb

但是,我这个系统里并没有 deb-src相关的仓库。
又上网找了这个

deb http://mirrors4.tuna.tsinghua.edu.cn/deepin/ apricot main contrib non-free
deb-src http://mirrors4.tuna.tsinghua.edu.cn/deepin/ apricot main contrib non-free

加入仓库后执行

apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 425956BB3E31DF51

然后再更新,就可以编译安装libseccomp2了,git上目前是2.5.1

标签: debian kylin

上一篇: 在arch下使用davinci-resolve
下一篇: idea-IU-222.4554.10 2022.2 破解和自动折叠方法,保存时格式化

添加新评论 »

*
*

欢迎评论!歡迎評論!Comments welcome!komentoj bonvenaj!댓글 오신 것을 환영합니다!
:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: :cold: :cryy: :cute: :shy: :sleep: :struggle: :tea: :yahou: